Welcome to forum Join us by registering now!
  • Login:
Ads
Dear user, please do not block ads, they help to maintain website.
 
Post Reply 
 
Thread Rating:
  • 15 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cube+ no lights turn on!
May-31-2016, 17:09 (This post was last modified: May-31-2016 17:22 by semperaye.)
Post: #1
Exclamation Cube+ no lights turn on!
I've had this cube+ for about a month, and have used it twice, about 10 pictures, and two videos. Today we decided to take some pictures using the app, the cube+ fired up fine and took great shots. I turned it off, then 30 minutes later decided to try to upload the photos to my PC. Now the cube+ will not turn on, the light doesn't turn on while charging either. Very disappointed...any tips?

WTH.

Here is how I just fixed it. Previously removing the SD card did nothing.

1.) Remove the SD card.

2.) Press and hold the power button for 10+ long seconds.

3.) Get very angry.

4.) Put the SD card back into the device.

5.) Try to turn on

6.) Repeat until it works tongue

Please let me know if this worked for you!
Find all posts by this user
Quote this message in a reply
Post Reply 


[-]
Share/Bookmark (Show All)
Facebook Twitter

Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Cube wont turn on wrjordan49 0 1,799 June-18-2015 20:16
Last Post: wrjordan49



User(s) browsing this thread: 1 Guest(s)


All rights reserved. Do not copy our content without permission.
We are not responsible for a content published by users.

To contact us by mail use: 4023 Kennett Pike 52943 | Wilmington | DE | 19807