Welcome to forum Join us by registering now!
  • Login:
Dear user, please do not block ads, they help to maintain website.
Post Reply 
Thread Rating:
  • 31 Votes - 2.81 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My Cube+ Worked for 15 Minutes
December-27-2015, 19:38
Post: #1
My Cube+ Worked for 15 Minutes
I got the Cube+ took it out of the box and it worked long enough to do one short test clip then it went to crap. I downloaded the app to my phone shot one little test clip, then the clip in the folder got deleted somehow. Then it would turn on for a second and go back off. The wifi woudn't come on. I thought it might need a charge so I plugged it in for a while. Now it won't come on at all and the light doesn't even flash when charging. Has anyone else had this experience???
Find all posts by this user
Quote this message in a reply
Post Reply 

Share/Bookmark (Show All)
Facebook Twitter

User(s) browsing this thread: 1 Guest(s)

All rights reserved. Do not copy our content without permission.
We are not responsible for a content published by users.

To contact us by mail use: 4023 Kennett Pike 52943 | Wilmington | DE | 19807